Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

(question) - not tested
(error) - incompatible
(warning) - not in update center

1.5.15.22.2774444112

SonarQube Version

3.03.13.23.33.43.53.6

3.7
LTS

4.04.1

Plugin / Release Date

Apr. 2012Jun. 2012Aug. 2012Nov. 2012Jan. 2013Mar. 2013Jun. 2013Aug. 2013Nov. 2013Jan. 2014
.NET2.12.12.12.12.12.12.12.12.12.1
Abacus0.10.10.10.10.10.10.10.10.10.1

ABAP

2.32.32.32.32.32.32.32.32.32.3

Android

(error)(error)(error)(error)(error)0.10.10.10.1

0.1

Artifact Size

0.30.20.20.20.20.20.20.20.20.2

Branding

0.40.40.40.40.40.40.40.40.40.4

Build Breaker

1.11.11.11.11.11.11.11.11.11.1

Build Stability

1.21.21.21.21.21.21.21.21.21.2
C/C++1.5.21.5.22.1.5.21.5.22.02.02.02.0

C#

2.12.12.12.12.12.12.12.12.12.1
Checkstyle

Embedded in
SonarQube Java Ecosystem

2.02.02.02.0
Chinese Pack(error)1.01.11.21.31.41.51.61.71.7

Clirr

1.11.11.11.11.11.11.11.11.11.1

Clover

2.92.92.92.92.92.92.92.92.92.9

Cobertura

(error)(error)(error)(error)(error)(error)1.41.41.41.4

Cobol

1.121.121.141.141.141.141.141.161.161.16

Crowd

1.01.01.01.01.01.01.01.01.01.0
Developer Cockpit1.01.01.2.21.2.21.1.2.21.3.11.3.11.3.11.3.1
Doxygen0.10.10.10.10.10.10.10.10.10.1
Drools0.20.20.2(error)(error)(error)(error)(error)(error)(error)

Eclipse

2.42.42.42.43.1.13.1.13.33.33.33.3

Emma

1.31.31.31.31.31.31.31.31.31.3
Erlang(error)(error)(error)0.10.20.20.20.20.20.2

fb-contrib

1.11.11.11.1(error)(error)1.21.21.21.2

Flex

1.21.22.02.02.02.02.02.02.02.0
Fortify1.11.11.11.11.11.11.11.11.11.1

French Pack

1.51.51.51.71.1.81.91.101.101.10
Issues Report Plugin(error)(error)(error)(error)(error)1.01.01.01.11.1

Greek Pack

1.41.51.61.71.1.81.81.81.81.8

Groovy

0.60.60.60.60.60.60.6(*)0.6(*)0.6(*)0.6(*)
Italian PackImage RemovedImage RemovedImage RemovedImage Removed 1.0 1.01.01.01.01.0
Japanese Pack(error)1.01.11.21.31.31.31.31.31.3

Java

Embedded in SonarQube Core

1.1 (warning)1.2 (warning)2.0(*)2.0(*)2.0(*)2.0(*)

JavaScript

1.45

1.

5

1.51.51.51.41.41.41.41.4

JIRA

0.35

JIRA

1.11.11.1.11.11.21.21.21.2

JMeter

0.20.20.20.20.20.20.20.20.20.2

LDAP

1.41.41.41.41.41.41.41.41.41.4

Mantis

0.30.30.30.30.30.30.30.30.30.3
Maven Report0.10.10.10.10.10.10.10.10.10.1

Motion Chart

1.21.41.41.41.51.51.51.51.51.5

Natural

1.2.41.2.41.2.41.2.41.2.41.2.41.2.41.2.41.2.41.2.4
OpenID(error)1.21.21.21.21.21.21.21.21.2

Pacbase

1.2.11.2.11.2.11.2.11.2.11.2.11.2.11.2.1(error)(error)

PAM

0.20.20.20.20.20.20.20.20.20.2

PDF Report

1.3.11.3.11.3.1.3.11.3.11.3.11.3.21.3.21.3.21.3.2

PHP

1.21.21.21.21.21.21.21.21.21.2
Pitest0.20.20.20.20.20.20.20.20.20.2

Piwik

1.01.01.01.01.01.01.01.01.01.0
PL/I1.21.21.21.21.21.21.21.21.21.2

PL/SQL

2.52.52.52.52.52.52.52.52.52.5
PMDEmbedded in
SonarQube Java Ecosystem
2.02.02.02.0
Portuguese Pack(error)(error)(error)1.01.11.11.11.11.11.1
Python1.11.11.11.11.11.11.11.11.11.1
Redmine(error)(error)(error)(error)(error)(error)0.10.10.10.1
Report(error)1.11.11.21.21.21.31.31.31.3

SCM Activity

1.61.61.61.61.61.61.61.61.61.6
SCM Stats0.20.20.0.20.20.20.3.10.3.10.3.10.3.1

Security Rules

0.3.20.3.20.3.20.3.20.3.20.3.20.3.20.3.20.3.20.3.2

SIGMM

1.0.11.0.11.0.11.0.11.0.11.0.11.0.11.0.11.0.11.0.1

Sonargraph

3.

0.3
3.0.53.0.63.0.6

3.1

3.13.13.13.13.1

Spanish Pack

1.61.61.71.71.81.91.101.101.111.11

SQALE

1.71.71.71.9.11.9.11.9.11.10.11.10.12.02.1
Tab Metrics1.41.41.41.41.41.41.41.41.41.4

Taglist

1.01.01.01.01.01.01.01.01.01.0
Thucydides0.10.10.10.10.10.10.10.10.10.1

Timeline

1.31.31.31.31.31.31.31.31.31.3
Toad CodeXpert1.01.01.01.01.01.01.01.01.01.0
Toxicity Chart0.10.10.10.10.10.10.10.10.10.1

Trac

0.30.30.30.30.30.30.30.30.30.3

Useless Code

0.60.60.60.60.60.60.60.60.60.6
VB.NET1.11.11.11.11.11.11.11.11.11.1

Views

1.8.11.8.11.8.11.8.12.0.22.0.22.2.22.2.22.3.12.4

Violation Density Plugin

1.21.21.21.21.21.21.21.21.21.2

Visual Basic 6

1.21.21.21.21.21.21.21.21.21.2

Web

2.02.02.12.12.12.12.12.12.12.1
Widget Lab1.11.11.31.31.31.31.31.31.31.3

XML

0.2

0.2

1.0.11.0.11.0.11.0.11.0.11.0.11.0.11.0.1

 

(*) Groovy 0.6 and Java Ecosystem 1.5 are not compatible with each other. Use Java Ecosystem 1.4 with Groovy 0.6 instead.