Commercial Edition Must Be Upgraded

Because a new server identifier will be generated at upgrade to this version, startup will fail unless you upgrade your commercial edition to the latest compatible version. 

SonarLint must be upgraded

Analyzers provided as part of a commercial package will be disabled in old versions of SonarLint. SonarLint users must upgrade to the latest available version:

Multi-version upgrade

Don't forget to read all the intermediate upgrade notes if you're upgrading more than a single version.